<!doctype html >
<!--[if IE 8]>    <html class="ie8" lang="en"> <![endif]-->
<!--[if IE 9]>    <html class="ie9" lang="en"> <![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US"> <!--<![endif]-->
<head>
<title>Filling the need: BISD looks for new staff with job fair | MyRGV.com</title>
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<link rel="pingback" href="https://myrgv.com/xmlrpc.php" />
<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />
<link rel="icon" type="image/png" href="https://myrgv.com/wp-content/uploads/2021/01/IMG_1280.jpg">

<meta name="description" content="The CAB cafeteria was full of hopeful job seekers Saturday morning at the Brownsville Independent School District’s job fair event." />
<link rel="canonical" href="https://myrgv.com/local-news/2021/10/02/filling-the-need-bisd-looks-for-new-staff-with-job-fair/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Filling the need: BISD looks for new staff with job fair" />
<meta property="og:description" content="The CAB cafeteria was full of hopeful job seekers Saturday morning at the Brownsville Independent School District’s job fair event." />
<meta property="og:url" content="https://myrgv.com/local-news/2021/10/02/filling-the-need-bisd-looks-for-new-staff-with-job-fair/" />
<meta property="og:site_name" content="MyRGV.com" />
<meta property="article:publisher" content="https://www.facebook.com/monitornews" />
<meta property="article:published_time" content="2021-10-03T01:43:29+00:00" />
<meta property="og:image" content="https://myrgv.com/wp-content/uploads/2021/10/getJPEG-3-scaled.jpg" />
<meta property="og:image:width" content="2560" />
<meta property="og:image:height" content="1707" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:label1" content="Written by" />
<meta name="twitter:data1" content="Denise Cathey - The Brownsville Herald" />
<meta name="twitter:label2" content="Est. reading time" />
<meta name="twitter:data2" content="2 minutes" />
<script type="application/ld+json" class="yoast-schema-graph">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</script>

<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="MyRGV.com &raquo; Feed" href="https://myrgv.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="MyRGV.com &raquo; Comments Feed" href="https://myrgv.com/comments/feed/" />
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/myrgv.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.8.1"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([10084,65039,8205,55357,56613],[10084,65039,8203,55357,56613])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='wp-block-library-css' href='https://myrgv.com/wp-includes/css/dist/block-library/style.min.css?ver=5.8.1' type='text/css' media='all' />
<link rel='stylesheet' id='td-plugin-newsletter-css' href='https://myrgv.com/wp-content/plugins/td-newsletter/style.css?ver=11.2' type='text/css' media='all' />
<link rel='stylesheet' id='td-plugin-multi-purpose-css' href='https://myrgv.com/wp-content/plugins/td-composer/td-multi-purpose/style.css?ver=5496ac087ca179a9788dadb779dbc160' type='text/css' media='all' />
<style id="google-fonts-style-css" media="all">@font-face {
  font-family: 'Open Sans';
  font-style: normal;
  font-weight: 400;
  font-display: swap;
  src: url(/fonts.gstatic.com/s/opensans/v23/mem8YaGs126MiZpBA-UFVZ0e.ttf) format('truetype');
}
@font-face {
  font-family: 'Open Sans';
  font-style: normal;
  font-weight: 600;
  font-display: swap;
  src: url(/fonts.gstatic.com/s/opensans/v23/mem5YaGs126MiZpBA-UNirkOUuhs.ttf) format('truetype');
}
@font-face {
  font-family: 'Open Sans';
  font-style: normal;
  font-weight: 700;
  font-display: swap;
  src: url(/fonts.gstatic.com/s/opensans/v23/mem5YaGs126MiZpBA-UN7rgOUuhs.ttf) format('truetype');
}
@font-face {
  font-family: 'Roboto';
  font-style: normal;
  font-weight: 400;
  font-display: swap;
  src: url(/fonts.gstatic.com/s/roboto/v27/KFOmCnqEu92Fr1Mu4mxP.ttf) format('truetype');
}
@font-face {
  font-family: 'Roboto';
  font-style: normal;
  font-weight: 500;
  font-display: swap;
  src: url(/fonts.gstatic.com/s/roboto/v27/KFOlCnqEu92Fr1MmEU9fBBc9.ttf) format('truetype');
}
@font-face {
  font-family: 'Roboto';
  font-style: normal;
  font-weight: 700;
  font-display: swap;
  src: url(/fonts.gstatic.com/s/roboto/v27/KFOlCnqEu92Fr1MmWUlfBBc9.ttf) format('truetype');
}
</style>
<link rel='stylesheet' id='td-theme-css' href='https://myrgv.com/wp-content/themes/Newspaper/style.css?ver=11.2' type='text/css' media='all' />
<style id='td-theme-inline-css' type='text/css'>
    
        @media (max-width: 767px) {
            .td-header-desktop-wrap {
                display: none;
            }
        }
        @media (min-width: 767px) {
            .td-header-mobile-wrap {
                display: none;
            }
        }
    
	
</style>
<link rel='stylesheet' id='td-legacy-framework-front-style-css' href='https://myrgv.com/wp-content/plugins/td-composer/legacy/Newspaper/assets/css/td_legacy_main.css?ver=5496ac087ca179a9788dadb779dbc160' type='text/css' media='all' />
<link rel='stylesheet' id='td-standard-pack-framework-front-style-css' href='https://myrgv.com/wp-content/plugins/td-standard-pack/Newspaper/assets/css/td_standard_pack_main.css?ver=9214a050dc0a6c6eeaa5c1aa35f9cfe3' type='text/css' media='all' />
<script type='text/javascript' src='https://myrgv.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>
<script type='text/javascript' src='https://myrgv.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<link rel="https://api.w.org/" href="https://myrgv.com/wp-json/" /><link rel="alternate" type="application/json" href="https://myrgv.com/wp-json/wp/v2/posts/95786" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://myrgv.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://myrgv.com/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 5.8.1" />
<link rel='shortlink' href='https://myrgv.com/?p=95786' />
<link rel="alternate" type="application/json+oembed" href="https://myrgv.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fmyrgv.com%2Flocal-news%2F2021%2F10%2F02%2Ffilling-the-need-bisd-looks-for-new-staff-with-job-fair%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://myrgv.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fmyrgv.com%2Flocal-news%2F2021%2F10%2F02%2Ffilling-the-need-bisd-looks-for-new-staff-with-job-fair%2F&#038;format=xml" />
<!--[if lt IE 9]><script src="https://cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7.3/html5shiv.js"></script><![endif]-->
<script>
        window.tdb_globals = {"wpRestNonce":"7f7e8ba050","wpRestUrl":"https:\/\/myrgv.com\/wp-json\/","permalinkStructure":"\/%category%\/%year%\/%monthnum%\/%day%\/%postname%\/","isAjax":false,"isAdminBarShowing":false,"autoloadScrollPercent":50,"postAutoloadStatus":"off","origPostEditUrl":null};
    </script>
<script>
				window.tdwGlobal = {"adminUrl":"https:\/\/myrgv.com\/wp-admin\/","wpRestNonce":"7f7e8ba050","wpRestUrl":"https:\/\/myrgv.com\/wp-json\/","permalinkStructure":"\/%category%\/%year%\/%monthnum%\/%day%\/%postname%\/"};
			</script>
<script>
        window.tdaGlobal = {"adminUrl":"https:\/\/myrgv.com\/wp-admin\/","wpRestNonce":"7f7e8ba050","wpRestUrl":"https:\/\/myrgv.com\/wp-json\/","permalinkStructure":"\/%category%\/%year%\/%monthnum%\/%day%\/%postname%\/","postId":95786};
    </script>

<script>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</script>

<style>
    
@media (max-width: 767px) {
        body .td-header-wrap .td-header-main-menu {
            background-color: #ffffff !important;
        }
    }


    
    @media (max-width: 767px) {
        body #td-top-mobile-toggle i,
        .td-header-wrap .header-search-wrap .td-icon-search {
            color: #222222 !important;
        }
    }
@media (max-width: 767px) {
        body .td-header-wrap .td-header-main-menu {
            background-color: #ffffff !important;
        }
    }


    
    @media (max-width: 767px) {
        body #td-top-mobile-toggle i,
        .td-header-wrap .header-search-wrap .td-icon-search {
            color: #222222 !important;
        }
    }
</style>

<script async src="https://www.googletagmanager.com/gtag/js?id=UA-58810203-12"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-58810203-12');
</script>

<script async='async' src='https://liqwid.net/?key=196A-5617-2B2F-5FBD'></script>

<script type="text/javascript" async="async" src="//widgets.outbrain.com/outbrain.js"></script>

<script id="scriptMg2Widget" src="https://prodmg2.blob.core.windows.net/newsletterwidget/aim/mg2nw.min.js">
</script>

<meta name="facebook-domain-verification" content="0krgytkkv3hvmpfjuswoek99k81vyr" />

<script type="text/javascript">var _sf_startpt=(new Date()).getTime()</script>

<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js?client=ca-pub-6904342588890055" crossorigin="anonymous"></script>
<script type="application/ld+json">
    {
        "@context": "http://schema.org",
        "@type": "BreadcrumbList",
        "itemListElement": [
            {
                "@type": "ListItem",
                "position": 1,
                "item": {
                    "@type": "WebSite",
                    "@id": "https://myrgv.com/",
                    "name": "Home"
                }
            },
            {
                "@type": "ListItem",
                "position": 2,
                    "item": {
                    "@type": "WebPage",
                    "@id": "https://myrgv.com/category/local-news/",
                    "name": "Local News"
                }
            }
            ,{
                "@type": "ListItem",
                "position": 3,
                    "item": {
                    "@type": "WebPage",
                    "@id": "https://myrgv.com/local-news/2021/10/02/filling-the-need-bisd-looks-for-new-staff-with-job-fair/",
                    "name": "Filling the need: BISD looks for new staff with job fair"                                
                }
            }    
        ]
    }
</script>
<style type="text/css" id="wp-custom-css">
			.td-main-page-wrap {
	padding-top: 0!important;
}
.td-header-style-7 .td-header-sp-logo img {
    width:auto!important;
}		</style>

<style>
    
</style>
<style id="tdw-css-placeholder">.td-header-style-7 .td-header-sp-logo img {
  width: auto!important;
}
.dfw-unit .display-block #TX_ROS_banner_header-auto-gen-id-4 {
  display: none!important;
}
</style></head>
<body class="post-template-default single single-post postid-95786 single-format-standard td-standard-pack filling-the-need-bisd-looks-for-new-staff-with-job-fair global-block-template-1 single_template_3 td-animation-stack-type0 td-full-layout" itemscope="itemscope" itemtype="https://schema.org/WebPage">
<div class="td-scroll-up  td-hide-scroll-up-on-mob" style="display:none;"><i class="td-icon-menu-up"></i></div>
<div class="td-menu-background"></div>
<div id="td-mobile-nav">
<div class="td-mobile-container">

<div class="td-menu-socials-wrap">

<div class="td-menu-socials">
</div>

<div class="td-mobile-close">
<a href="#" aria-label="Close"><i class="td-icon-close-mobile"></i></a>
</div>
</div>


<div class="td-mobile-content">
<div class="menu-main-container"><ul id="menu-main" class="td-mobile-main-menu"><li id="menu-item-102" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-first menu-item-102"><a href="https://myrgv.com/category/local-news/">News<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
<li id="menu-item-868" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-868"><a href="https://myrgv.com/category/local-news/">Local News</a></li>
<li id="menu-item-871" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-871"><a href="https://myrgv.com/category/wire/">Outside the Valley</a></li>
<li id="menu-item-869" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-869"><a href="https://myrgv.com/category/media/">Multimedia</a></li>
<li id="menu-item-1082" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-1082"><a href="https://myrgv.com/category/the-brownsville-herald/">The Brownsville Herald</a></li>
<li id="menu-item-1081" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1081"><a href="https://myrgv.com/category/the-monitor/">The Monitor</a></li>
<li id="menu-item-1083" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-1083"><a href="https://myrgv.com/category/valley-morning-star/">Valley Morning Star<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
<li id="menu-item-91593" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-91593"><a href="https://readerschoicevms.myrgv.com/">VMS 2021 Readers Choice Winners</a></li>
</ul>
</li>
<li id="menu-item-82962" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-82962"><a href="https://elnuevoheraldo.com/">El Nuevo Heraldo</a></li>
</ul>
</li>
<li id="menu-item-78696" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-78696"><a href="https://myrgv.com/category/local-news/elections/">Elections<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
<li id="menu-item-93997" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-93997"><a href="https://myrgv.com/category/meet-the-candidate/">Meet Local Candidates</a></li>
<li id="menu-item-78697" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-78697"><a href="https://myrgv.com/local-news/2021/04/18/what-to-know-about-early-voting-in-hidalgo-county/">Hidalgo County Voting Resource</a></li>
</ul>
</li>
<li id="menu-item-7531" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-7531"><a href="https://myrgv.com/coronavirus/">COVID News</a></li>
<li id="menu-item-108" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-108"><a href="#">Obituaries<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
<li id="menu-item-113" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-113"><a href="https://www.legacy.com/obituaries/themonitor/">The Monitor</a></li>
<li id="menu-item-120" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-120"><a href="https://www.legacy.com/obituaries/valleystar/">Valley Morning Star</a></li>
<li id="menu-item-119" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-119"><a href="https://www.legacy.com/obituaries/brownsvilleherald/">Brownsville Herald</a></li>
</ul>
</li>
<li id="menu-item-214" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-214"><a href="https://myrgv.com/category/sports/">Sports</a></li>
<li id="menu-item-1537" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-1537"><a href="#">Subscribe<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
<li id="menu-item-1539" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1539"><a href="https://myrgv.com/subscribe-the-monitor/">The Monitor</a></li>
<li id="menu-item-1538" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1538"><a href="https://myrgv.com/subscribe-valley-morning-star/">Valley Morning Star</a></li>
<li id="menu-item-1540" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1540"><a href="https://myrgv.com/subscribe-brownsville-herald/">Brownsville Herald</a></li>
<li id="menu-item-1674" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1674"><a href="https://myrgv.com/newsletters/">Newsletters</a></li>
</ul>
</li>
<li id="menu-item-220" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-220"><a href="#">E-Edition<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
<li id="menu-item-221" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-221"><a href="http://themonitor.tx.newsmemory.com/">The Monitor</a></li>
<li id="menu-item-219" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-219"><a href="http://valleymorningstar.tx.newsmemory.com/">Valley Morning Star</a></li>
<li id="menu-item-222" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-222"><a href="https://brownsvilleherald-tx.newsmemory.com/">Brownsville Herald</a></li>
</ul>
</li>
<li id="menu-item-284" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-284"><a href="#">Classifieds<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
<li id="menu-item-252" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-252"><a href="https://www.jobmatchtexas.com/">JobMatchTexas</a></li>
<li id="menu-item-285" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-285"><a href="https://valleywideclassifieds.onlineads.advpubtech.com/showads">Valley Wide Classifieds</a></li>
<li id="menu-item-287" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-287"><a href="#">Legal Notices<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
<li id="menu-item-4378" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4378"><a href="http://texaspublicnotices.com/">Texas Public Notices</a></li>
<li id="menu-item-4379" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4379"><a href="http://www.mypublicnotices.com/themonitor/PublicNotice.asp">My Public Notices</a></li>
</ul>
</li>
<li id="menu-item-8984" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-8984"><a href="https://myrgv.com/careers/">Careers</a></li>
</ul>
</li>
<li id="menu-item-292" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-292"><a href="#">More<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
<li id="menu-item-1086" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-1086"><a href="#">Manage Account<i class="td-icon-menu-right td-element-after"></i></a>
<ul class="sub-menu">
<li id="menu-item-1087" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1087"><a href="https://aimiservices.newscyclecloud.com/cgi-bin/cmo_aim-c-cmdb-01.sh/custservice/web/login.html?siteid=MCM">The Monitor</a></li>
<li id="menu-item-1272" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1272"><a href="https://aimiservices.newscyclecloud.com/cgi-bin/cmo_aim-c-cmdb-01.sh/custservice/web/login.html?siteid=HAV">Valley Morning Star</a></li>
<li id="menu-item-1258" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1258"><a href="https://aimiservices.newscyclecloud.com/cgi-bin/cmo_aim-c-cmdb-01.sh/custservice/web/login.html?siteid=BRC">Brownsville Herald</a></li>
</ul>
</li>
<li id="menu-item-1507" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1507"><a href="https://local.myrgv.com/">Marketplace</a></li>
<li id="menu-item-79185" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-79185"><a href="https://myrgv.com/giveaways/">Giveaways</a></li>
<li id="menu-item-290" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-290"><a href="https://myrgv.com/privacy-policy-2/">Privacy Policy</a></li>
<li id="menu-item-1914" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1914"><a href="https://myrgv.com/category/ask-the-expert/">Ask the Expert</a></li>
<li id="menu-item-291" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-291"><a href="https://myrgv.com/contact-us/">Contact Us</a></li>
<li id="menu-item-8983" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-8983"><a href="https://myrgv.com/careers/">Careers</a></li>
</ul>
</li>
</ul></div> </div>
</div>

</div> <div class="td-search-background"></div>
<div class="td-search-wrap-mob">
<div class="td-drop-down-search">
<form method="get" class="td-search-form" action="https://myrgv.com/">

<div class="td-search-close">
<a href="#"><i class="td-icon-close-mobile"></i></a>
</div>
<div role="search" class="td-search-input">
<span>Search</span>
<input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" />
</div>
</form>
<div id="td-aj-search-mob" class="td-ajax-search-flex"></div>
</div>
</div>
<div id="td-outer-wrap" class="td-theme-wrap">
<div class="tdc-header-wrap ">

<div class="td-header-wrap td-header-style-7 ">
<div class="td-header-top-menu-full td-container-wrap td_stretch_container td_stretch_content_1600">
<div class="td-container td-header-row td-header-top-menu">
<div class="top-bar-style-1">
<div class="td-header-sp-top-menu">
</div>
<div class="td-header-sp-top-widget">
<div class="td-search-btns-wrap">
<a id="td-header-search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
</div>
<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
<form method="get" class="td-search-form" action="https://myrgv.com/">
<div role="search" class="td-head-form-search-wrap">
<input id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" />
</div>
</form>
<div id="td-aj-search"></div>
</div>
</div> </div>

<div id="login-form" class="white-popup-block mfp-hide mfp-with-anim">
<div class="td-login-wrap">
<a href="#" aria-label="Back" class="td-back-button"><i class="td-icon-modal-back"></i></a>
<div id="td-login-div" class="td-login-form-div td-display-block">
<div class="td-login-panel-title">Sign in</div>
<div class="td-login-panel-descr">Welcome! Log into your account</div>
<div class="td_display_err"></div>
<form action="#" method="post">
<div class="td-login-inputs"><input class="td-login-input" autocomplete="username" type="text" name="login_email" id="login_email" value="" required><label for="login_email">your username</label></div>
<div class="td-login-inputs"><input class="td-login-input" autocomplete="current-password" type="password" name="login_pass" id="login_pass" value="" required><label for="login_pass">your password</label></div>
<input type="button" name="login_button" id="login_button" class="wpb_button btn td-login-button" value="Login">
</form>
<div class="td-login-info-text"><a href="#" id="forgot-pass-link">Forgot your password? Get help</a></div>
</div>
<div id="td-forgot-pass-div" class="td-login-form-div td-display-none">
<div class="td-login-panel-title">Password recovery</div>
<div class="td-login-panel-descr">Recover your password</div>
<div class="td_display_err"></div>
<div class="td-login-inputs"><input class="td-login-input" type="text" name="forgot_email" id="forgot_email" value="" required><label for="forgot_email">your email</label></div>
<input type="button" name="forgot_button" id="forgot_button" class="wpb_button btn td-login-button" value="Send My Password">
<div class="td-login-info-text">A password will be e-mailed to you.</div>
</div>
</div>
</div>
</div>
</div>
<div class="td-header-menu-wrap-full td-container-wrap td_stretch_container td_stretch_content_1600">
<div class="td-header-menu-wrap td-header-gradient td-header-menu-no-search">
<div class="td-container td-header-row td-header-main-menu">
<div class="td-header-sp-logo">
<a class="td-main-logo" href="https://myrgv.com/">
<img class="td-retina-data" data-retina="https://myrgv.com/wp-content/uploads/2021/01/IMG_1284.jpg" src="https://myrgv.com/wp-content/uploads/2021/01/IMG_1284.jpg" alt="" width="1920" height="843" />
<span class="td-visual-hidden">MyRGV.com</span>
</a>
</div>
<div class="td-search-wrapper">
<div id="td-top-search">

<div class="header-search-wrap">
<div class="dropdown header-search">
<a id="td-header-search-button-mob" href="#" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
</div>
</div>
</div>
</div>
<div id="td-header-menu" role="navigation">
<div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div>
<div class="td-main-menu-logo td-logo-in-header">
<a class="td-main-logo" href="https://myrgv.com/">
<img class="td-retina-data" data-retina="https://myrgv.com/wp-content/uploads/2021/01/IMG_1284.jpg" src="https://myrgv.com/wp-content/uploads/2021/01/IMG_1284.jpg" alt="" width="1920" height="843" />
</a>
</div>
<div class="menu-main-container"><ul id="menu-main-1" class="sf-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-first td-menu-item td-normal-menu menu-item-102"><a href="https://myrgv.com/category/local-news/">News</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-normal-menu menu-item-868"><a href="https://myrgv.com/category/local-news/">Local News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-871"><a href="https://myrgv.com/category/wire/">Outside the Valley</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-869"><a href="https://myrgv.com/category/media/">Multimedia</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-normal-menu menu-item-1082"><a href="https://myrgv.com/category/the-brownsville-herald/">The Brownsville Herald</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-1081"><a href="https://myrgv.com/category/the-monitor/">The Monitor</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children td-menu-item td-normal-menu menu-item-1083"><a href="https://myrgv.com/category/valley-morning-star/">Valley Morning Star</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-91593"><a href="https://readerschoicevms.myrgv.com/">VMS 2021 Readers Choice Winners</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-82962"><a href="https://elnuevoheraldo.com/">El Nuevo Heraldo</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children td-menu-item td-normal-menu menu-item-78696"><a href="https://myrgv.com/category/local-news/elections/">Elections</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-93997"><a href="https://myrgv.com/category/meet-the-candidate/">Meet Local Candidates</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-78697"><a href="https://myrgv.com/local-news/2021/04/18/what-to-know-about-early-voting-in-hidalgo-county/">Hidalgo County Voting Resource</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-7531"><a href="https://myrgv.com/coronavirus/">COVID News</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children td-menu-item td-normal-menu menu-item-108"><a href="#">Obituaries</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-113"><a href="https://www.legacy.com/obituaries/themonitor/">The Monitor</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-120"><a href="https://www.legacy.com/obituaries/valleystar/">Valley Morning Star</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-119"><a href="https://www.legacy.com/obituaries/brownsvilleherald/">Brownsville Herald</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-214"><a href="https://myrgv.com/category/sports/">Sports</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children td-menu-item td-normal-menu menu-item-1537"><a href="#">Subscribe</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-1539"><a href="https://myrgv.com/subscribe-the-monitor/">The Monitor</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-1538"><a href="https://myrgv.com/subscribe-valley-morning-star/">Valley Morning Star</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-1540"><a href="https://myrgv.com/subscribe-brownsville-herald/">Brownsville Herald</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-1674"><a href="https://myrgv.com/newsletters/">Newsletters</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children td-menu-item td-normal-menu menu-item-220"><a href="#">E-Edition</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-221"><a href="http://themonitor.tx.newsmemory.com/">The Monitor</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-219"><a href="http://valleymorningstar.tx.newsmemory.com/">Valley Morning Star</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-222"><a href="https://brownsvilleherald-tx.newsmemory.com/">Brownsville Herald</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children td-menu-item td-normal-menu menu-item-284"><a href="#">Classifieds</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-252"><a href="https://www.jobmatchtexas.com/">JobMatchTexas</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-285"><a href="https://valleywideclassifieds.onlineads.advpubtech.com/showads">Valley Wide Classifieds</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children td-menu-item td-normal-menu menu-item-287"><a href="#">Legal Notices</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-4378"><a href="http://texaspublicnotices.com/">Texas Public Notices</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-4379"><a href="http://www.mypublicnotices.com/themonitor/PublicNotice.asp">My Public Notices</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-8984"><a href="https://myrgv.com/careers/">Careers</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children td-menu-item td-normal-menu menu-item-292"><a href="#">More</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children td-menu-item td-normal-menu menu-item-1086"><a href="#">Manage Account</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-1087"><a href="https://aimiservices.newscyclecloud.com/cgi-bin/cmo_aim-c-cmdb-01.sh/custservice/web/login.html?siteid=MCM">The Monitor</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-1272"><a href="https://aimiservices.newscyclecloud.com/cgi-bin/cmo_aim-c-cmdb-01.sh/custservice/web/login.html?siteid=HAV">Valley Morning Star</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-1258"><a href="https://aimiservices.newscyclecloud.com/cgi-bin/cmo_aim-c-cmdb-01.sh/custservice/web/login.html?siteid=BRC">Brownsville Herald</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-1507"><a href="https://local.myrgv.com/">Marketplace</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-79185"><a href="https://myrgv.com/giveaways/">Giveaways</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-290"><a href="https://myrgv.com/privacy-policy-2/">Privacy Policy</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-1914"><a href="https://myrgv.com/category/ask-the-expert/">Ask the Expert</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-291"><a href="https://myrgv.com/contact-us/">Contact Us</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-8983"><a href="https://myrgv.com/careers/">Careers</a></li>
</ul>
</li>
</ul></div></div> </div>
</div>
</div>
<div class="td-banner-wrap-full td-container-wrap td_stretch_container td_stretch_content_1600">
<div class="td-container-header td-header-row td-header-header">
<div class="td-header-sp-recs">
<div class="td-header-rec-wrap">
<div class="td-a-rec td-a-rec-id-header  tdi_1 td_block_template_1">
<style>
/* custom css */
.tdi_1.td-a-rec{
					text-align: center;
				}.tdi_1 .td-element-style{
					z-index: -1;
				}.tdi_1.td-a-rec-img{
				    text-align: left;
				}.tdi_1.td-a-rec-img img{
                    margin: 0 auto 0 0;
                }@media (max-width: 767px) {
				    .tdi_1.td-a-rec-img {
				        text-align: center;
				    }
                }
</style><div id="doubleclick_widget-6" class="td_block_template_1 widget widget_doubleclick_widget widget-shortcode area-td-high-impact "><div class='dfw-unit' data-adunit='MON_HighImpactBox' data-size-mapping='mapping1'></div></div></div>
</div> </div>
</div>
</div>
</div>
</div>
<article id="post-95786" class="td-post-template-3 post-95786 post type-post status-publish format-standard has-post-thumbnail category-the-brownsville-herald tag-brownsville-isd tag-education td-container-wrap" itemscope itemtype="https://schema.org/Article">
<div class="td-post-header td-container">
<div class="td-crumb-container"><div class="entry-crumbs"><span><a title="" class="entry-crumb" href="https://myrgv.com/">Home</a></span> <i class="td-icon-right td-bread-sep"></i> <span><a title="View all posts in Local News" class="entry-crumb" href="https://myrgv.com/category/local-news/">Local News</a></span> <i class="td-icon-right td-bread-sep td-bred-no-url-last"></i> <span class="td-bred-no-url-last">Filling the need: BISD looks for new staff with job fair</span></div></div>
<div class="td-post-header-holder td-image-gradient">
<div class="td-post-featured-image"><figure><a href="https://myrgv.com/wp-content/uploads/2021/10/getJPEG-3-scaled.jpg" data-caption="Job applicants fill out their online applications at one of the many computer stations set up throughout the room Saturday for the Brownsville Independent School District&#039;s Job Fair in the CAB cafeteria. (Denise Cathey/The Brownsville Herald)"><img width="1068" height="712" class="entry-thumb td-modal-image" src="https://myrgv.com/wp-content/uploads/2021/10/getJPEG-3-1068x712.jpg" srcset="https://myrgv.com/wp-content/uploads/2021/10/getJPEG-3-1068x712.jpg 1068w, https://myrgv.com/wp-content/uploads/2021/10/getJPEG-3-2136x1424.jpg 2136w" sizes="(-webkit-min-device-pixel-ratio: 2) 2136px, (min-resolution: 192dpi) 2136px, 1068px" alt="" title="BISD Job Fair" /></a><figcaption class="wp-caption-text">Job applicants fill out their online applications at one of the many computer stations set up throughout the room Saturday for the Brownsville Independent School District's Job Fair in the CAB cafeteria. (Denise Cathey/The Brownsville Herald)</figcaption></figure></div>
<header class="td-post-title">
<ul class="td-category"><li class="entry-category"><a href="https://myrgv.com/category/local-news/">Local News</a></li><li class="entry-category"><a href="https://myrgv.com/category/the-brownsville-herald/">The Brownsville Herald</a></li></ul> <h1 class="entry-title">Filling the need: BISD looks for new staff with job fair</h1>
<div class="td-module-meta-info">
<div class="td-post-author-name"><div class="td-author-by">By</div> <a href="https://myrgv.com/author/dcathey/">Denise Cathey - The Brownsville Herald</a><div class="td-author-line"> - </div> </div> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2021-10-02T20:43:29-05:00">October 2, 2021</time></span> </div>
</header>
</div>
</div>
<div class="td-container">
<div class="td-pb-row">
<div class="td-pb-span8 td-main-content" role="main">
<div class="td-ss-main-content">
<div class="td-post-sharing-top"><div id="td_social_sharing_article_top" class="td-post-sharing td-ps-bg td-ps-notext td-post-sharing-style1 ">
<style>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</style>
<div class="td-post-sharing-visible"><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fmyrgv.com%2Flocal-news%2F2021%2F10%2F02%2Ffilling-the-need-bisd-looks-for-new-staff-with-job-fair%2F" title="Facebook">
<div class="td-social-but-icon"><i class="td-icon-facebook"></i></div>
<div class="td-social-but-text">Facebook</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=Filling+the+need%3A+BISD+looks+for+new+staff+with+job+fair&url=https%3A%2F%2Fmyrgv.com%2Flocal-news%2F2021%2F10%2F02%2Ffilling-the-need-bisd-looks-for-new-staff-with-job-fair%2F&via=MyRGV.com" title="Twitter">
<div class="td-social-but-icon"><i class="td-icon-twitter"></i></div>
<div class="td-social-but-text">Twitter</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-pinterest" href="https://pinterest.com/pin/create/button/?url=https://myrgv.com/local-news/2021/10/02/filling-the-need-bisd-looks-for-new-staff-with-job-fair/&amp;media=https://myrgv.com/wp-content/uploads/2021/10/getJPEG-3-scaled.jpg&description=The CAB cafeteria was full of hopeful job seekers Saturday morning at the Brownsville Independent School District’s job fair event." title="Pinterest">
<div class="td-social-but-icon"><i class="td-icon-pinterest"></i></div>
<div class="td-social-but-text">Pinterest</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-whatsapp" href="https://api.whatsapp.com/send?text=Filling+the+need%3A+BISD+looks+for+new+staff+with+job+fair %0A%0A https://myrgv.com/local-news/2021/10/02/filling-the-need-bisd-looks-for-new-staff-with-job-fair/" title="WhatsApp">
<div class="td-social-but-icon"><i class="td-icon-whatsapp"></i></div>
<div class="td-social-but-text">WhatsApp</div>
</a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_social_sharing_article_top" title="More">
<div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div>
</a></div></div></div>
<div class="td-post-content tagdiv-type">
<p class="Body_Copy">The CAB cafeteria was full of hopeful job seekers Saturday morning at the Brownsville Independent School District’s job fair event.</p>
<p class="Body_Copy">The job fair was organized after the number of resignations and retirements among staff increased due to the COVID-19 pandemic, leaving the district short on hands as classes switched from physical to remote and back again.</p>
<p class="Body_Copy">“We have been trying to balance schedules and classes based on the staff members that we have, but we need to fill in the vacancies that we have as soon as possible,” Dr. René Gutiérrez, BISD Superintendent, said.</p>
<p class="Body_Copy">Hoping to fill over 100 positions, the event which ran from 8:00 a.m. until noon, addressed the district-wide staff shortage, especially in the areas of Special Education, Transportation, and teachers for the Common Core curriculum subjects like Math and Science.</p>
<figure id="attachment_95788" aria-describedby="caption-attachment-95788" style="width: 2560px" class="wp-caption aligncenter"><img loading="lazy" class="size-full wp-image-95788" src="https://myrgv.com/wp-content/uploads/2021/10/getJPEG-2-scaled.jpg" alt="" width="2560" height="1707" srcset="https://myrgv.com/wp-content/uploads/2021/10/getJPEG-2-scaled.jpg 2560w, https://myrgv.com/wp-content/uploads/2021/10/getJPEG-2-300x200.jpg 300w, https://myrgv.com/wp-content/uploads/2021/10/getJPEG-2-1024x683.jpg 1024w, https://myrgv.com/wp-content/uploads/2021/10/getJPEG-2-768x512.jpg 768w, https://myrgv.com/wp-content/uploads/2021/10/getJPEG-2-1536x1024.jpg 1536w, https://myrgv.com/wp-content/uploads/2021/10/getJPEG-2-2048x1365.jpg 2048w, https://myrgv.com/wp-content/uploads/2021/10/getJPEG-2-600x400.jpg 600w, https://myrgv.com/wp-content/uploads/2021/10/getJPEG-2-696x464.jpg 696w, https://myrgv.com/wp-content/uploads/2021/10/getJPEG-2-1392x928.jpg 1392w, https://myrgv.com/wp-content/uploads/2021/10/getJPEG-2-1068x712.jpg 1068w, https://myrgv.com/wp-content/uploads/2021/10/getJPEG-2-1920x1280.jpg 1920w" sizes="(max-width: 2560px) 100vw, 2560px" /><figcaption id="caption-attachment-95788" class="wp-caption-text">Yolanda Turbeville, Principal at Peña Elementary, helps answer questions from applicants Yolanda Perez and Brooke Espinosa Saturday for the Brownsville Independent School District&#8217;s Job Fair in the CAB cafeteria. (Denise Cathey/The Brownsville Herald)</figcaption></figure>
<p class="Body_Copy">In the case of the Transportation Office, Director Eliud Ornelas expressed that there is an urgent need for roughly 43 bus drivers, to help get operations back on track for the district.</p><div class="td-a-rec td-a-rec-id-content_inlineleft  tdi_2 td_block_template_1">
<style>
/* custom css */
.tdi_2.td-a-rec{
					text-align: center;
				}.tdi_2 .td-element-style{
					z-index: -1;
				}.tdi_2.td-a-rec-img{
				    text-align: left;
				}.tdi_2.td-a-rec-img img{
                    margin: 0 auto 0 0;
                }@media (max-width: 767px) {
				    .tdi_2.td-a-rec-img {
				        text-align: center;
				    }
                }
</style><div id="doubleclick_widget-9" class="td_block_template_1 widget widget_doubleclick_widget widget-shortcode area-td-in-article-ad "><div class='dfw-unit' data-adunit='TX-InArticle-box' data-size-mapping='mapping2'></div></div></div>
<p class="Body_Copy">According to Ornelas, this problem is part of a larger national shortage of drivers that affects everything from the oil industry to the availability of taxis on the street.</p>
<p class="Body_Copy">“It is delaying all the routes to take the kids to school. We are packing the school buses because of that and doing double runs instead of the single runs that we used to do,” he said.</p>
<p class="Body_Copy">Additionally any competitive events students attend pulls drivers out of the small pool that service the day-to-day operations of the district.</p>
<figure id="attachment_95787" aria-describedby="caption-attachment-95787" style="width: 2560px" class="wp-caption aligncenter"><img loading="lazy" class="size-full wp-image-95787" src="https://myrgv.com/wp-content/uploads/2021/10/getJPEG-4-scaled.jpg" alt="" width="2560" height="1707" srcset="https://myrgv.com/wp-content/uploads/2021/10/getJPEG-4-scaled.jpg 2560w, https://myrgv.com/wp-content/uploads/2021/10/getJPEG-4-300x200.jpg 300w, https://myrgv.com/wp-content/uploads/2021/10/getJPEG-4-1024x683.jpg 1024w, https://myrgv.com/wp-content/uploads/2021/10/getJPEG-4-768x512.jpg 768w, https://myrgv.com/wp-content/uploads/2021/10/getJPEG-4-1536x1024.jpg 1536w, https://myrgv.com/wp-content/uploads/2021/10/getJPEG-4-2048x1365.jpg 2048w, https://myrgv.com/wp-content/uploads/2021/10/getJPEG-4-600x400.jpg 600w, https://myrgv.com/wp-content/uploads/2021/10/getJPEG-4-696x464.jpg 696w, https://myrgv.com/wp-content/uploads/2021/10/getJPEG-4-1392x928.jpg 1392w, https://myrgv.com/wp-content/uploads/2021/10/getJPEG-4-1068x712.jpg 1068w, https://myrgv.com/wp-content/uploads/2021/10/getJPEG-4-1920x1280.jpg 1920w" sizes="(max-width: 2560px) 100vw, 2560px" /><figcaption id="caption-attachment-95787" class="wp-caption-text">Sandra Barron-Herrera, Dean of Instruction at Garcia Middle School, takes down substitute applicant Nory Gabriela Boeta&#8217;s information Saturday for the Brownsville Independent School District&#8217;s Job Fair in the CAB cafeteria. (Denise Cathey/The Brownsville Herald)</figcaption></figure>
<p class="Body_Copy">In order to simplify things, BISD created a streamlined process for its applicants to come in and fill out an online job application at one of the many computer stations throughout the cafeteria for the event. Once the application was done, applicants then went directly into an interview with an interview committee from that department or campus and those recommended for hire could receive their employment contract that day.</p>
<p class="Body_Copy">Ahead of the event, Gutiérrez received authorization from the BISD’s Board of Trustees to directly hire staff, so applicants will start their new jobs in the district shortly, pending the required background check and fingerprinting.</p>
<p class="Body_Copy">The district reports that by 9:30 a.m. they had already received over 150 applicants for the available positions, with a total of 242 applications submitted by the end of the event.</p>
<div class="td-a-rec td-a-rec-id-content_bottom  tdi_3 td_block_template_1">
<style>
/* custom css */
.tdi_3.td-a-rec{
					text-align: center;
				}.tdi_3 .td-element-style{
					z-index: -1;
				}.tdi_3.td-a-rec-img{
				    text-align: left;
				}.tdi_3.td-a-rec-img img{
                    margin: 0 auto 0 0;
                }@media (max-width: 767px) {
				    .tdi_3.td-a-rec-img {
				        text-align: center;
				    }
                }
</style><div id="custom_html-6" class="widget_text td_block_template_1 widget widget_custom_html widget-shortcode area-td-outbrain "><div class="textwidget custom-html-widget"><div class="OUTBRAIN" data-src="DROP_PERMALINK_HERE" data-widget-id="GS_4"></div></div></div></div> </div>
<footer>
<div class="td-post-source-tags">
<ul class="td-tags td-post-small-box clearfix"><li><span>TAGS</span></li><li><a href="https://myrgv.com/tag/bisd/">BISD</a></li><li><a href="https://myrgv.com/tag/brownsville/">Brownsville</a></li><li><a href="https://myrgv.com/tag/brownsville-isd/">Brownsville ISD</a></li><li><a href="https://myrgv.com/tag/education/">education</a></li></ul> </div>
<div class="td-post-sharing-bottom"><div class="td-post-sharing-classic"><iframe frameBorder="0" src="https://www.facebook.com/plugins/like.php?href=https://myrgv.com/local-news/2021/10/02/filling-the-need-bisd-looks-for-new-staff-with-job-fair/&amp;layout=button_count&amp;show_faces=false&amp;width=105&amp;action=like&amp;colorscheme=light&amp;height=21" style="border:none; overflow:hidden; width:auto; height:21px; background-color:transparent;"></iframe></div><div id="td_social_sharing_article_bottom" class="td-post-sharing td-ps-bg td-ps-notext td-post-sharing-style1 "><div class="td-post-sharing-visible"><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fmyrgv.com%2Flocal-news%2F2021%2F10%2F02%2Ffilling-the-need-bisd-looks-for-new-staff-with-job-fair%2F" title="Facebook">
<div class="td-social-but-icon"><i class="td-icon-facebook"></i></div>
<div class="td-social-but-text">Facebook</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=Filling+the+need%3A+BISD+looks+for+new+staff+with+job+fair&url=https%3A%2F%2Fmyrgv.com%2Flocal-news%2F2021%2F10%2F02%2Ffilling-the-need-bisd-looks-for-new-staff-with-job-fair%2F&via=MyRGV.com" title="Twitter">
<div class="td-social-but-icon"><i class="td-icon-twitter"></i></div>
<div class="td-social-but-text">Twitter</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-pinterest" href="https://pinterest.com/pin/create/button/?url=https://myrgv.com/local-news/2021/10/02/filling-the-need-bisd-looks-for-new-staff-with-job-fair/&amp;media=https://myrgv.com/wp-content/uploads/2021/10/getJPEG-3-scaled.jpg&description=The CAB cafeteria was full of hopeful job seekers Saturday morning at the Brownsville Independent School District’s job fair event." title="Pinterest">
<div class="td-social-but-icon"><i class="td-icon-pinterest"></i></div>
 <div class="td-social-but-text">Pinterest</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-whatsapp" href="https://api.whatsapp.com/send?text=Filling+the+need%3A+BISD+looks+for+new+staff+with+job+fair %0A%0A https://myrgv.com/local-news/2021/10/02/filling-the-need-bisd-looks-for-new-staff-with-job-fair/" title="WhatsApp">
<div class="td-social-but-icon"><i class="td-icon-whatsapp"></i></div>
<div class="td-social-but-text">WhatsApp</div>
</a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_social_sharing_article_bottom" title="More">
<div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div>
</a></div></div></div> <div class="td-block-row td-post-next-prev"><div class="td-block-span6 td-post-prev-post"><div class="td-post-next-prev-content"><span>Previous article</span><a href="https://myrgv.com/featured/2021/10/02/dhr-donates-medical-beds-to-hidalgo-isd-for-covid-isolation-rooms/">DHR donates medical beds to Hidalgo ISD for COVID isolation rooms</a></div></div><div class="td-next-prev-separator"></div></div> <div class="author-box-wrap"><a href="https://myrgv.com/author/dcathey/" aria-label="author-photo"><img alt='' src='https://secure.gravatar.com/avatar/2b0fbc27ac96c7141696f7b868047fbc?s=96&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/2b0fbc27ac96c7141696f7b868047fbc?s=192&#038;d=mm&#038;r=g 2x' class='avatar avatar-96 photo' height='96' width='96' loading='lazy' /></a><div class="desc"><div class="td-author-name vcard author"><span class="fn"><a href="https://myrgv.com/author/dcathey/">Denise Cathey - The Brownsville Herald</a></span></div><div class="td-author-description">Denise Cathey is a photojournalist for the Brownsville Herald. She also pokes at data on occasion, tries (and sometimes fails) to keep her plants alive, and is ever in search of the ultimate cup of coffee. She can be reached at <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="395d5a584d515c40795b4b564e574a4f5055555c515c4b58555d175a565417">[email&#160;protected]</a></div><div class="td-author-social"></div><div class="clearfix"></div></div></div> <span class="td-page-meta" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="Denise Cathey - The Brownsville Herald"></span><meta itemprop="datePublished" content="2021-10-02T20:43:29-05:00"><meta itemprop="dateModified" content="2021-10-02T20:43:29-05:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://myrgv.com/local-news/2021/10/02/filling-the-need-bisd-looks-for-new-staff-with-job-fair/" /><span class="td-page-meta" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span class="td-page-meta" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://myrgv.com/wp-content/uploads/2021/01/IMG_1284.jpg"></span><meta itemprop="name" content="MyRGV.com"></span><meta itemprop="headline " content="Filling the need: BISD looks for new staff with job fair"><span class="td-page-meta" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://myrgv.com/wp-content/uploads/2021/10/getJPEG-3-scaled.jpg"><meta itemprop="width" content="2560"><meta itemprop="height" content="1707"></span> </footer>
<div class="td_block_wrap td_block_related_posts tdi_4 td_with_ajax_pagination td-pb-border-top td_block_template_1" data-td-block-uid="tdi_4"><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>var block_tdi_4 = new tdBlock();
block_tdi_4.id = "tdi_4";
block_tdi_4.atts = '{"limit":3,"ajax_pagination":"next_prev","live_filter":"cur_post_same_categories","td_ajax_filter_type":"td_custom_related","class":"tdi_4","td_column_number":3,"block_type":"td_block_related_posts","live_filter_cur_post_id":95786,"live_filter_cur_post_author":"98","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_ajax_preloading":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","tdc_css_class":"tdi_4","tdc_css_class_style":"tdi_4_rand_style"}';
block_tdi_4.td_column_number = "3";
block_tdi_4.block_type = "td_block_related_posts";
block_tdi_4.post_count = "3";
block_tdi_4.found_posts = "11059";
block_tdi_4.header_color = "";
block_tdi_4.ajax_pagination_infinite_stop = "";
block_tdi_4.max_num_pages = "3687";
tdBlocksArray.push(block_tdi_4);
</script><h4 class="td-related-title td-block-title"><a id="tdi_5" class="td-related-left td-cur-simple-item" data-td_filter_value="" data-td_block_id="tdi_4" href="#">RELATED ARTICLES</a><a id="tdi_6" class="td-related-right" data-td_filter_value="td_related_more_from_author" data-td_block_id="tdi_4" href="#">MORE FROM AUTHOR</a></h4><div id=tdi_4 class="td_block_inner">
<div class="td-related-row">
<div class="td-related-span4">
<div class="td_module_related_posts td-animation-stack td_mod_related_posts">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://myrgv.com/featured/2021/10/02/dhr-donates-medical-beds-to-hidalgo-isd-for-covid-isolation-rooms/" rel="bookmark" class="td-image-wrap " title="DHR donates medical beds to Hidalgo ISD for COVID isolation rooms"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="DHR donates medical beds to Hidalgo ISD for COVID isolation rooms" data-type="image_tag" data-img-url="https://myrgv.com/wp-content/uploads/2021/10/IMG_8337-218x150.jpg" data-img-retina-url="https://myrgv.com/wp-content/uploads/2021/10/IMG_8337-436x300.jpg" width="218" height="150" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://myrgv.com/featured/2021/10/02/dhr-donates-medical-beds-to-hidalgo-isd-for-covid-isolation-rooms/" rel="bookmark" title="DHR donates medical beds to Hidalgo ISD for COVID isolation rooms">DHR donates medical beds to Hidalgo ISD for COVID isolation rooms</a></h3> </div>
</div>
</div> 
<div class="td-related-span4">
<div class="td_module_related_posts td-animation-stack td_mod_related_posts">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://myrgv.com/life/2021/10/02/sharing-their-journey-oncologist-survivor-raise-breast-cancer-awareness-as-dhr-health-discounts-mammograms/" rel="bookmark" class="td-image-wrap " title="Sharing their journey: Oncologist, survivor raise breast cancer awareness as DHR Health discounts mammograms"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Sharing their journey: Oncologist, survivor raise breast cancer awareness as DHR Health discounts mammograms" data-type="image_tag" data-img-url="https://myrgv.com/wp-content/uploads/2021/10/Untitled-4-218x150.jpg" data-img-retina-url="https://myrgv.com/wp-content/uploads/2021/10/Untitled-4-436x300.jpg" width="218" height="150" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://myrgv.com/life/2021/10/02/sharing-their-journey-oncologist-survivor-raise-breast-cancer-awareness-as-dhr-health-discounts-mammograms/" rel="bookmark" title="Sharing their journey: Oncologist, survivor raise breast cancer awareness as DHR Health discounts mammograms">Sharing their journey: Oncologist, survivor raise breast cancer awareness as DHR Health discounts mammograms</a></h3> </div>
</div>
</div> 
<div class="td-related-span4">
<div class="td_module_related_posts td-animation-stack td_mod_related_posts">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://myrgv.com/sports/2021/10/02/tarpons-stay-unbeaten-with-district-win-over-bearkats/" rel="bookmark" class="td-image-wrap " title="Tarpons stay unbeaten with district win over Bearkats"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Tarpons stay unbeaten with district win over Bearkats" data-type="image_tag" data-img-url="https://myrgv.com/wp-content/uploads/2021/03/35e2664969ac094e718366c20916c208-218x150.jpg" data-img-retina-url="https://myrgv.com/wp-content/uploads/2021/03/35e2664969ac094e718366c20916c208-436x300.jpg" width="218" height="150" /></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://myrgv.com/sports/2021/10/02/tarpons-stay-unbeaten-with-district-win-over-bearkats/" rel="bookmark" title="Tarpons stay unbeaten with district win over Bearkats">Tarpons stay unbeaten with district win over Bearkats</a></h3> </div>
</div>
</div> </div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" aria-label="prev-page" id="prev-page-tdi_4" data-td_block_id="tdi_4"><i class="td-next-prev-icon td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" aria-label="next-page" id="next-page-tdi_4" data-td_block_id="tdi_4"><i class="td-next-prev-icon td-icon-font td-icon-menu-right"></i></a></div></div> 
</div>
</div>
<div class="td-pb-span4 td-main-sidebar" role="complementary">
<div class="td-ss-main-sidebar">
<aside id="doubleclick_widget-7" class="td_block_template_1 widget doubleclick_widget-7 widget_doubleclick_widget"><div class='dfw-unit dfw-lazy-load' data-adunit='TX-ROS-box-pos1' data-size-mapping='mapping3'></div></aside><aside id="doubleclick_widget-8" class="td_block_template_1 widget doubleclick_widget-8 widget_doubleclick_widget"><div class='dfw-unit dfw-lazy-load' data-adunit='TX-ROS-box-pos-2' data-size-mapping='mapping4'></div></aside><aside id="doubleclick_widget-10" class="td_block_template_1 widget doubleclick_widget-10 widget_doubleclick_widget"><div class='dfw-unit dfw-lazy-load' data-adunit='TX-ROS-box-pos-3' data-size-mapping='mapping5'></div></aside> </div>
</div>
</div> 
</div> 
</article> 

<div class="tdc-footer-wrap ">

<div class="td-footer-wrapper td-footer-container td-container-wrap ">
<div class="td-container">
<div class="td-pb-row">
<div class="td-pb-span12">
<div class="td-a-rec td-a-rec-id-footer_top  tdi_7 td_block_template_1">
<style>
/* custom css */
.tdi_7.td-a-rec{
					text-align: center;
				}.tdi_7 .td-element-style{
					z-index: -1;
				}.tdi_7.td-a-rec-img{
				    text-align: left;
				}.tdi_7.td-a-rec-img img{
                    margin: 0 auto 0 0;
                }@media (max-width: 767px) {
				    .tdi_7.td-a-rec-img {
				        text-align: center;
				    }
                }
</style><div id="doubleclick_widget-5" class="td_block_template_1 widget widget_doubleclick_widget widget-shortcode area-td-footer-leaderboard "><div class='dfw-unit' data-adunit='TX-ROS-banner-footer' data-size-mapping='mapping6'></div></div></div> </div>
</div>
<div class="td-pb-row">
<div class="td-pb-span12">
<aside class="widget_text td_block_template_1 widget widget_custom_html"><div class="textwidget custom-html-widget"><style>
 .div1 {
  padding: -30px;
align-content: right;
	
}
.smallimg {
padding: 10px 5px
	
} 
	.spacer {
		
	}
</style>
<center><div class="div1"><div>
<img src="https://myrgv.com/wp-content/uploads/2021/01/IMG_1286-1024x454.jpg" alt="My Rgv News" width="300" height="170">
<br>
<h3 style="color:white;">
Powered by:
</h3>
<a href="https://myrgv.com/category/the-monitor/">
<img class="smallimg" src="https://myrgv.com/wp-content/uploads/2021/01/TheMonitor_Trans_White_1200w-300x62-1.png" alt="The Monitor" width="300" height="52">
</a>
<a href="https://myrgv.com/category/valley-morning-star/">
<img class="smallimg" src="https://myrgv.com/wp-content/uploads/2021/01/vms-trnas-white-300x52.png" alt="Valley Morning Star" width="300" height="52">
</a>
<a href="https://myrgv.com/category/the-brownsville-herald/">
<img class="smallimg" src="https://myrgv.com/wp-content/uploads/2021/01/bh-trans-small2-copy.png" alt="The Brownville Herald" width="300" height="52">
</a>
</div>
</div></center></div></aside> </div>
</div>
</div>
</div>

<div class="td-sub-footer-container td-container-wrap ">
<div class="td-container">
<div class="td-pb-row">
<div class="td-pb-span td-sub-footer-menu">
<div class="menu-main-container"><ul id="menu-main-2" class="td-subfooter-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-first td-menu-item td-normal-menu menu-item-102"><a href="https://myrgv.com/category/local-news/">News</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-normal-menu menu-item-868"><a href="https://myrgv.com/category/local-news/">Local News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-871"><a href="https://myrgv.com/category/wire/">Outside the Valley</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-869"><a href="https://myrgv.com/category/media/">Multimedia</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-normal-menu menu-item-1082"><a href="https://myrgv.com/category/the-brownsville-herald/">The Brownsville Herald</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-1081"><a href="https://myrgv.com/category/the-monitor/">The Monitor</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children td-menu-item td-normal-menu menu-item-1083"><a href="https://myrgv.com/category/valley-morning-star/">Valley Morning Star</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-91593"><a href="https://readerschoicevms.myrgv.com/">VMS 2021 Readers Choice Winners</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-82962"><a href="https://elnuevoheraldo.com/">El Nuevo Heraldo</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children td-menu-item td-normal-menu menu-item-78696"><a href="https://myrgv.com/category/local-news/elections/">Elections</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-93997"><a href="https://myrgv.com/category/meet-the-candidate/">Meet Local Candidates</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-78697"><a href="https://myrgv.com/local-news/2021/04/18/what-to-know-about-early-voting-in-hidalgo-county/">Hidalgo County Voting Resource</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-7531"><a href="https://myrgv.com/coronavirus/">COVID News</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children td-menu-item td-normal-menu menu-item-108"><a href="#">Obituaries</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-113"><a href="https://www.legacy.com/obituaries/themonitor/">The Monitor</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-120"><a href="https://www.legacy.com/obituaries/valleystar/">Valley Morning Star</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-119"><a href="https://www.legacy.com/obituaries/brownsvilleherald/">Brownsville Herald</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-214"><a href="https://myrgv.com/category/sports/">Sports</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children td-menu-item td-normal-menu menu-item-1537"><a href="#">Subscribe</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-1539"><a href="https://myrgv.com/subscribe-the-monitor/">The Monitor</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-1538"><a href="https://myrgv.com/subscribe-valley-morning-star/">Valley Morning Star</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-1540"><a href="https://myrgv.com/subscribe-brownsville-herald/">Brownsville Herald</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-1674"><a href="https://myrgv.com/newsletters/">Newsletters</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children td-menu-item td-normal-menu menu-item-220"><a href="#">E-Edition</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-221"><a href="http://themonitor.tx.newsmemory.com/">The Monitor</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-219"><a href="http://valleymorningstar.tx.newsmemory.com/">Valley Morning Star</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-222"><a href="https://brownsvilleherald-tx.newsmemory.com/">Brownsville Herald</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children td-menu-item td-normal-menu menu-item-284"><a href="#">Classifieds</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-252"><a href="https://www.jobmatchtexas.com/">JobMatchTexas</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-285"><a href="https://valleywideclassifieds.onlineads.advpubtech.com/showads">Valley Wide Classifieds</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children td-menu-item td-normal-menu menu-item-287"><a href="#">Legal Notices</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-4378"><a href="http://texaspublicnotices.com/">Texas Public Notices</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-4379"><a href="http://www.mypublicnotices.com/themonitor/PublicNotice.asp">My Public Notices</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-8984"><a href="https://myrgv.com/careers/">Careers</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children td-menu-item td-normal-menu menu-item-292"><a href="#">More</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children td-menu-item td-normal-menu menu-item-1086"><a href="#">Manage Account</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-1087"><a href="https://aimiservices.newscyclecloud.com/cgi-bin/cmo_aim-c-cmdb-01.sh/custservice/web/login.html?siteid=MCM">The Monitor</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-1272"><a href="https://aimiservices.newscyclecloud.com/cgi-bin/cmo_aim-c-cmdb-01.sh/custservice/web/login.html?siteid=HAV">Valley Morning Star</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-1258"><a href="https://aimiservices.newscyclecloud.com/cgi-bin/cmo_aim-c-cmdb-01.sh/custservice/web/login.html?siteid=BRC">Brownsville Herald</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-1507"><a href="https://local.myrgv.com/">Marketplace</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-79185"><a href="https://myrgv.com/giveaways/">Giveaways</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-290"><a href="https://myrgv.com/privacy-policy-2/">Privacy Policy</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-1914"><a href="https://myrgv.com/category/ask-the-expert/">Ask the Expert</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-291"><a href="https://myrgv.com/contact-us/">Contact Us</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-8983"><a href="https://myrgv.com/careers/">Careers</a></li>
</ul>
</li>
</ul></div> </div>
<div class="td-pb-span td-sub-footer-copy">
&copy; Copyright <a href="https://www.digitalaimmedia.com" target="_blank">AIM Media Texas, LLC</a> </div>
</div>
</div>
</div>
</div>
</div>
<a rel="nofollow" style="display:none;" href="https://myrgv.com/?blackhole=7d5aeed30d" title="Do NOT follow this link or you will be banned from the site!">MyRGV.com</a>


<style type="text/css" media="screen">
/* custom css theme panel */
/*Newsletter Button Styling*/
.nlbutton {
  background-color: red;
  border: none;
  color: white;
  padding: 15px 32px;
  text-align: center;
  text-decoration: none;
  display: inline-block;
  font-size: 30px;
  margin: 4px 2px;
  cursor: pointer;
  line-height: 1.5;
  font-weight: bold;
}

#mg2Widget-newsletter-container .pm__wrapper {
    z-index: 9999 !important;
}
/*End Newsletter Button Styling*/

/*Mobile background color
@media screen and (max-width: 767px){
.td-header-wrap .td-header-menu-wrap-full, .td-header-wrap .td-header-menu-wrap, .td-header-wrap .td-header-main-menu {
background-color: #fff!important;
height: 54px!important;
}
}
End mobile background color*/
</style>
<div class="td-container"><div>text</div></div><link rel='stylesheet' id='dfp-css' href='https://myrgv.com/wp-content/plugins/doubleclick-for-wp/css/dfp.css?ver=0.2.0.1' type='text/css' media='all' />
<script type='text/javascript' src='https://myrgv.com/wp-includes/js/underscore.min.js?ver=1.13.1' id='underscore-js'></script>
<script type='text/javascript' src='https://myrgv.com/wp-content/plugins/td-cloud-library/assets/js/js_posts_autoload.min.js?ver=c19aec6a20dc470dea3def4ce71e04d5' id='tdb_js_posts_autoload-js'></script>
<script type='text/javascript' src='https://myrgv.com/wp-content/plugins/td-composer/legacy/Newspaper/js/tagdiv_theme.min.js?ver=11.2' id='td-site-min-js'></script>
<script type='text/javascript' src='https://myrgv.com/wp-includes/js/comment-reply.min.js?ver=5.8.1' id='comment-reply-js'></script>
<script type='text/javascript' src='https://myrgv.com/wp-content/plugins/td-cloud-library/assets/js/js_files_for_front.min.js?ver=c19aec6a20dc470dea3def4ce71e04d5' id='tdb_js_files_for_front-js'></script>
<script type='text/javascript' src='https://myrgv.com/wp-includes/js/wp-embed.min.js?ver=5.8.1' id='wp-embed-js'></script>
<script type='text/javascript' src='https://myrgv.com/wp-content/plugins/doubleclick-for-wp/js/vendor/jquery.dfp.js/jquery.dfp.min.js?ver=0.2.0.1' id='jquery.dfp.js-js'></script>
<script type='text/javascript' id='jquery.dfw.js-js-extra'>
/* <![CDATA[ */
var dfw = {"networkCode":null,"mappings":{"mapping1":[{"browser":[769,1],"ad_sizes":[[970,250]]},{"browser":[481,1],"ad_sizes":[[320,100]]},{"browser":[0,1],"ad_sizes":[[320,100]]}],"mapping2":[{"browser":[769,1],"ad_sizes":[[300,250]]},{"browser":[481,1],"ad_sizes":[[300,250]]},{"browser":[0,1],"ad_sizes":[[300,250]]}],"mapping3":[{"browser":[769,1],"ad_sizes":[[300,250]]},{"browser":[481,1],"ad_sizes":[[300,250]]},{"browser":[0,1],"ad_sizes":[[300,250]]}],"mapping4":[{"browser":[769,1],"ad_sizes":[[300,250]]},{"browser":[481,1],"ad_sizes":[[300,250]]},{"browser":[0,1],"ad_sizes":[[300,250]]}],"mapping5":[{"browser":[769,1],"ad_sizes":[[300,250]]},{"browser":[481,1],"ad_sizes":[[300,250]]},{"browser":[0,1],"ad_sizes":[[300,250]]}],"mapping6":[{"browser":[769,1],"ad_sizes":[[728,90]]},{"browser":[481,1],"ad_sizes":[[320,100]]},{"browser":[0,1],"ad_sizes":[[320,100]]}]},"targeting":{"Page":["single"],"Category":["local-news","the-brownsville-herald"],"Tag":["bisd","brownsville","brownsville-isd","education"]}};
/* ]]> */
</script>
<script type='text/javascript' src='https://myrgv.com/wp-content/plugins/doubleclick-for-wp/js/jquery.dfw.js?ver=0.2.0.1' id='jquery.dfw.js-js'></script>
<script type="text/javascript">
				jQuery('.dfw-unit:not(.dfw-lazy-load)').dfp({
					dfpID: '6230954',
					collapseEmptyDivs: false,
					setTargeting: {"Page":["single"],"Category":["local-news","the-brownsville-herald"],"Tag":["bisd","brownsville","brownsville-isd","education"]},
					sizeMapping: {"mapping1":[{"browser":[769,1],"ad_sizes":[[970,250]]},{"browser":[481,1],"ad_sizes":[[320,100]]},{"browser":[0,1],"ad_sizes":[[320,100]]}],"mapping2":[{"browser":[769,1],"ad_sizes":[[300,250]]},{"browser":[481,1],"ad_sizes":[[300,250]]},{"browser":[0,1],"ad_sizes":[[300,250]]}],"mapping3":[{"browser":[769,1],"ad_sizes":[[300,250]]},{"browser":[481,1],"ad_sizes":[[300,250]]},{"browser":[0,1],"ad_sizes":[[300,250]]}],"mapping4":[{"browser":[769,1],"ad_sizes":[[300,250]]},{"browser":[481,1],"ad_sizes":[[300,250]]},{"browser":[0,1],"ad_sizes":[[300,250]]}],"mapping5":[{"browser":[769,1],"ad_sizes":[[300,250]]},{"browser":[481,1],"ad_sizes":[[300,250]]},{"browser":[0,1],"ad_sizes":[[300,250]]}],"mapping6":[{"browser":[769,1],"ad_sizes":[[728,90]]},{"browser":[481,1],"ad_sizes":[[320,100]]},{"browser":[0,1],"ad_sizes":[[320,100]]}]}				});
			</script>

<script async src="https://www.googletagmanager.com/gtag/js?id=G-9QCDEZHFR9"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'G-9QCDEZHFR9');
</script>

<script type="text/javascript">
  var _sf_async_config = { uid: 20837, domain: 'myrgv.com', useCanonical: true };
  (function() {
    function loadChartbeat() {
      window._sf_endpt = (new Date()).getTime();
      var e = document.createElement('script');
      e.setAttribute('language', 'javascript');
      e.setAttribute('type', 'text/javascript');
      e.setAttribute('src','//static.chartbeat.com/js/chartbeat.js');
      document.body.appendChild(e);
    };
    var oldonload = window.onload;
    window.onload = (typeof window.onload != 'function') ?
      loadChartbeat : function() { oldonload(); loadChartbeat(); };
  })();
</script>

<script>
    
</script>
<script defer src="https://static.cloudflareinsights.com/beacon.min.js" data-cf-beacon='{"rayId":"6982d3bd7a1757d3","token":"ad39be4ab96f44b4aebe01a7546c8839","version":"2021.9.0","si":100}'></script>
</body>
</html>